Compas installation error


I have installed Compas-dev and Compas-fofin following

The installation process of both went on smoothly, but when I tried to run examples such as shortestpath_plot, dynamicrelaxation_live, etc., errors began to show up.

Looking forward to your suggestions and thank you so much for the help!

Best regards

those examples don’t work in rhino because they use matplotlib in the background and that package is not available for ironpython, which is the version of python embedded in rhino.
the plotters provide basic 2d visualisation that can be used outside of CAD environments for generating images or during prototyping of algorithms.
just run them from vscode or any other editor you like using, but not the pythonscript editor inside rhino.
let me know if you need more help…


Thanks for your timely reply, those examples work well in vscode! But back in rhino, when directly using fofin function, it shows error again…Can you please give some advice?

Thank you!
Best regards

can you give me a bit more info about what you are doing? it is a bit difficult to decipher from the screenshots…
also, did you install COMPAS from source or from a released version?

I was trying form-finding analysis for a fabric formwork.I initiated FOFIN in Rhino, typed FOFIN_from, selected from_mesh option, then selected a mesh, but as soon as I selected a mesh, an erorr message showed up, saying “cannot import _PrimitiveArtist”. Then I pressed “OK” button, and typed FOFIN_from again, a message appeared, saying “cablenet”…

As for COMPAS installation, I followed instructions on
I tried to installed COMPAS in both base environment and compas-dev environment. And here is a screenshot showing the installation process.

Thank you so much for looking after this issue! I have been trying sometime to solve this problem on my own, but still cannot figure out where went wrong…

Best Regards

I also verified the installation, everything seems fine…

there seems to be a bug in release 0.13.1 in the imports of the artists in compas_rhino. it is an easy fix so i will release a new version later today. updating COMPAS to that version should solve the issue.
will notify here in a post as soon as it is ready…

as far as i can tell the problem should be solved.
just update COMPAS to 0.13.2 and compas_fofin to the latest source release.
let me know if you still have problems…

and if you don’t :slight_smile:

Hi! Very sorry for my late reply, I have to finish some physical tests at the end of semester and I just get some time to focus on the software issue.

I removed previous compas-dev environment and the compas package in base environment, and installed the compas 0.13.2, yet, while verifying in Grasshopper, a URL Error showed up as in the uploaded picture.

Thank you so much for your kind help!

Best Regards

I have tried another computer to install compas and compas fofin, and they are all functioning successfully! So maybe it is something wrong with my own computer since I am running windows on a mac? Sorry for occupying so much time of yours, maybe it’s time to change my computer…

Another question, how can I install compas_ags? I typed “pip install compas_ags” and it shows"cannot find a version that satisefies the requirement" as in the uploaded picture…

Best regards

1 Like

compas_ags indeed needs to be updated, both the source code and the documentation.
i will post here when that is done…

Many Thanks!! When do you think it can be completed?

probably by the end of this week

It sounds great! Thank you!


a basic version of compas_ags with updated installation instructions should be available again.
let me know if you still experience problems.

note that compas_ags will soon become part of a “Graphic Statics” bundle for COMPAS and that all UI related developments will be moved to that project…


Thanks for the update, I have successfully installed ags! but when I tried to run in Rhino Python Editor the example post by Tom, it says cannot import geometric_key_xy…

By the way, my intention to use compas_fofin as well as compas_ags is to optimize the branch force distribution within a cable net, so that it can best fit the target geometry…I have read articles written by Tom and Veenendaal on this subject to understand the principles, but do you think such work can be achieved by using compas_fofin and compas_ags?


a few things…

  • it turned out that there were a few issues with release 0.15.0. best to update to 0.15.1 (or update your local repo if you installed from source).
  • the example is not meant to be used inside rhino since it uses its own viewer to display results. the viewer uses matplotlib in the background and is therefore not available in ironpython based environments and thus not in rhino.
  • the code of the examples has been slightly updated. better to get the latest version there as well.

about the second part of your question.

compas_fofin and compas_ags indeed provide some basic tools to build your own “best-fit” algorithm. however, the BRG versions have not yet been open-sourced.


Thanks for the timely notification :smiley:!