COMPAS PATH - Message: No module named compas


#1

Good afternoon,

Is it possible to specify more how to add the path to COMPAS?
Below I am highlighting the website and on top of that I am adding my screen, but it is not working.

|585x500

All the best!
Thomaz


#2

Hi Thomaz,

COMPAS 0.3.0 was recently released. This is the first version that is pip and conda installable, so it is not necessary to add paths anymore. The online documentation explains how to install COMPAS from a command line:

https://compas-dev.github.io/main/gettingstarted.html

Paths in Rhino can be added as shown here:

https://compas-dev.github.io/main/environments.html

Best,

TiME
.


#3

Hi Mendéz,

I tryed the conda installable and it didn´t work. I thought the reason could be the proxy from university, but it is still not working from home.

The packages is working in the python, but not ironpython. Any other suggestion?

Best Thomaz


#4

Hi @Thomaz,

Could you please copy/paste the error message you’re receiving?

The next release of COMPAS -scheduled to be released in the coming days- will use a different method to install on Rhino, so, perhaps you’re bumping into an issue that has been fixed already, but please add the error here so that we can understand a bit better.

Cheers
Gonzalo


#5

Hi Gonzalo,

I think I got the same problem as Thomaz encountered. Compas was successfully installed to python but not ironpython. And it seems that python cannot figure out where the compas_rhino.install is.

Best
Yuzhou


#6

the install script is indeed not yet available in 0.3.0. it is already available through the github repo and it will be part of release 0.3.1


#7

fyi, compas 0.3.1 with the rhino install script is now available…


#8

Hi,

I tried installing rhino compas using following code: python -m compas_rhino.install 6.0 in the command line, and am getting following message:

but when I try to import compas_rhino in a rhino-script i get the error: ‘No module named compas_rhino’

What am I doing wrong?


#9

try running this from a command prompt with admin privileges…


#10

also, i see you are using miniconda. not sure if this makes a difference, but why not a full version of anaconda?