compas_fofin-UI Error

Hi everyone,

my compas_fofin-UI keep showing this Error if I’m trying to use fofin_attribute or update_xyz
I’ve tried restart my Proxy server, reinstall compas_fofin and compas_fofin-UI but nothing seems to work…
I also checked the dev folder all the is there… so…

Is there any way to fix this?



hi finn,

there have been quite a few changes recently and the error you see is caused by those changes.

  • compas_fofin-UI has been integrated into compas_fofin
  • COMPAS has a new system for making Rhino Command Menus and the dict error is a result of that
  • installation of Python CommandPlugin UIs has been simplified in recent COMPAS versions
  • the commands of the UI have been split up into simpler parts.

i would recommend to delete you current fofin environment and start from scratch following the Getting Started instructions in the docs:

you will be the first using the new setup, so there might be a small hickup here and there :slight_smile:
please report back or post issues and i will try to smoothen things out as needed…


Hi Tom,

Thank you!
I update my compas_fofin and everything works fine until I try to use FOFIN_update_xyz

I’ve tried to restart my Proxy server but still showing me this ERROR

am I not install it successfully?

Thank you again,


the latest released version of COMPAS is lagging behind a bit, so perhaps you should install COMPAS from source as well.

cd path/to/compas
pip install -e .