Conda environment in VS Code on OSX

When I am working in VS Code on Mac, I can’t launch a Proxy server for RPC calls directly from VS Code. In addition, when I launch an Integrated Terminal in VS Code and type which python, the return value points to the system Python shipped with my OS instead of the Python of my conda environment.

To solve this add this to the settings.json of your project folder or change it globally in the settings of VS Code

"terminal.integrated.inheritEnv": false