Connect to two robots from one computer


We have been trying to change the IP address to one of our gofa robots so that we can connect to two of them from the same computer but so far we were unsuccessful.

We tried two ways:

  1. From the teach pendant, after modifying the IP, it asks to restart the controller and then the IP remains the same
  2. From Robotstudio we tried to modify the IP under Controller<Configuration<Properties<network Settings and got back this error message:

Url: Cmd:Set Prop:LANAdaptorIP Args:-Address -Submask -Gateway -PortSpeed Auto Elapsed:1 CurrentCmds:0
… 5/1/2023 2:17:24 PM Controllers

We got a hint from @fleischp that we should rather connect through the WAN port and any further information on how to proceed further would be much appreciated :slight_smile:

Correct. Normally, you would not change the “service port” ip address (I’m not even sure if it can be changed at all?), so instead of that, you change the ip address of the WAN port. I don’t have the GoFa at hand, but isn’t it listed in the Settings -> Network screen of the flex pendant? I believe the default of the WAN port is something like 192.168.10.x.

Hi @gonzalocasas Thanks a lot! Our mistake was trying to change the WAN port also to 192.168.125.x. It worked perfectly fine with 192.168.10.xand we could connect to RRC :slight_smile: Just in case someone else is reading this in the future, I note that we also had to change the computer IP to something similar.

Now still we can only connect to one robot at a time. We are using 2 usb-c ports with ethernet adapters and ping doesn’t work for both robots at the same time. Only seperatly. So perhaps we need an ethernet splitter? Don’t know whether you would have any advice on that…

For the docker side, I have an example with two abb drivers from a previous project so that should work.

Thanks again!

I think creating two sub-nets sharing the same range (ie. 192.168.10.x on two adapters) might be problematic, I would suggest two different ones, so one adapter uses something like 192.168.10.x and the other 192.168.20.x.

Does this diagram clarifies what I mean?


1 Like

Worked! Both robots are connected to RRC! :robot: :robot:

1 Like