Solver (ipopt) did not exit normally - compas_cra

Hallo there,

I was attenting the recent online workshop where we have done amazing stuff in compas about Discrete Element Modeling and Robotic Fabrication in Compas, Rhino and Grasshopper. Thanks again for very successful and interesting workshop!
Anyway I was going through the workshop material and whole process on my office computer and when I came to folder day2/03 of the materials, compas_cra doesn’t work and when I run the first example I get this Error:
File “C:\Users\zlata\anaconda3\envs\mcneel22\lib\site-packages\pyomo\opt\base\”, line 596, in solve
raise ApplicationError(
pyomo.common.errors.ApplicationError: Solver (ipopt) did not exit normally

Do you maybe have any idea what it can be? I have tried installing compas_cra again but nothing changed.
Thanks a lot for help in advance!
Best regards!


it could be the version of ipopt.
try installing the version that is needed for windows specifically to see if that helps.

conda activate mcneel22
conda install ipopt=3.11.1