Supporting compas<2.0 in compas_notebook?

Hi all,

I pinned compas-notebook=0.3.3 some time ago as a dependency for jax_fdm and it worked like a charm. Until Github actions told me otherwise last week.

Is there a pip- or conda-installable version of compas-notebook that supports compas<2.0 out of the box?

I was surprised not only to see that version 0.3.3 was not available on pypi anymore, but that all previous and subsequent published versions of compas-notebook on pypi require compas>2.0.
jax_fdm will be pinned to compas<2.0 for the next couple of months, but I need compas-notebook to continue working smoothly with a group of collaborators for the coming weeks on a project that relies on displaying stuff on jupyter notebooks / google colab.

Thanks for your help,

hi rafael,

compas_notebook is indeed meant for COMPAS 2 only, and has no releases that are compatible with COMPAS 1.

the version of compas_notebook that was available on PyPI for COMPAS 1 was unfortunately a very old and accidental release that has been replaced completely.

if you let me know which functionality you need specifically, perhaps we can come up with a temp solution for your current collaboration?


@Li_Chen do you still have a version of the old compas_notebook backed up somewhere?

@arpastrana i have sent an invitation for the old archived repo to arpastrana on github…

@arpastrana could you check if a source install with this repo works for you? then we can take it from there…

Hey @tomvanmele, thanks for the access to the old repo! I got it. Let me test the source install later today and get back to you as soon as I have news.

Hi @tomvanmele. I have cloned and installed that repo from source. I need to mirror the code to a public repository on my account to be able to install it on google collab via !pip install git+<repo url>. I went ahead and did it to check if it works on collab. It does. But to double check, would we be okay with me republishing the code? Thanks.

yes, no problem. happy that the problem is solved…

Excellent, thanks for helping me resolve this!
In other things, is there a summary somewhere that informs compas developers about what changed (especially what doesn’t work anymore) between compas 1 and 2, and how to migrate between versions? This would be very helpful to speed up the transitioning.

yes, we are working on a migration guide for the docs. i will add a first draft soon. we will also go through most of this during the developer day on the 30th of May…

1 Like

Wish I could go! But you know, Zurich is a bit far at the moment :nerd_face: Looking forward to the outcomes of the dev day and to the migration guide!