Compas installing error

Hi, When I try to install Compas get start. I have 404 error; File not found

Hi @Mohammadrezaarch

Do you get this error after you type the conda install .... compas line in the terminal? Or where exactly?


I think ,404,it has solved, But I cant install. I dont know where I can type,conda install … compas, this? I tried it inside the rhino command and not worked, and I don’t know where I can type in anacoda? becaused ithas different environments.

You should type the installation commands from the Anaconda Prompt. You can find it if you open the Start menu of Windows, and start typing Anaconda Prompt in there. It should open something like this:

In that window, type the following lines:

conda config --add channels conda-forge
conda create -n NAME_OF_YOUR_ENVIRONMENT python=3.8 compas --yes

(obviously replace NAME_OF_YOUR_ENVIRONMENT for whatever you want to name the environment)

Once the install is done, you can:

  1. activate it with:
  1. make it available inside Rhino:
python -m compas_rhino.install


You had a typo when you added conda-forge the first time:

Try removing it first:

conda config --remove channels conda-foge

and then retry the installation.

thank you for your helping, I think it,s installed

1 Like

Yay! Looking good! :dancer:

Check the docs, this is a documented scenario:

What happens is that you probably haven’t ever installed any build tools on that machine, so, you need a one-off install of Visual C++ stuff. (Actually, if you see inside the whole pile of error messages, this is what it says, it’s just a bit hard to read in the mess of text).

Thank you so much, I instaled build tools.
when I try to " pip install -e
the massage is that: -e option requires an argument

You can only use pip install to install from local disc. For that you have to download the repositories you want to install from BRGs gitbhub manually or use a client like Sourcetree or SmartGit. After downloading open conda prompt navigate to the folder of the downloaded repository via cd command and then you can use pip install -e . to install it.

For example, I downloaded Compas singular. So, How can I give navigation of this folder to aconda prompt? Is there any place for instruction, to follow?

“from compas_plotters.meshplotter import MeshPlotter” Also this comand doesnt work. I dont know from where I can install it.

Your normal path in command prompt is C:\Users\username There I have a folder named Code with the path C:\Users\username\Code and my compas_singular folder is at C:\Users\username\Code\compas_singular.

To navigate there I type cd Code/compas_singular. Check how the change directory cd command works e.g. here:

Regarding the mesh plotter, I’m not sure, a lot of the artists (maybe also plotters?) work only directly in rhino python - but I might be wrong. The script you copied is ment for rhino python, most examples in the gitbook are.
For examples of compas_singular in gh go to compas_/singular/examples/grasshopper, there are some gh example files and user objects you can use.

Thank you. I did this process, But PIP install -e . dont work again.

I guess the best explanation for manual installation of compas packages is the rv2 gitbook: It also shows how to pip install it directly from github without manual download

Regarding your screencap: Did you download the master branch of compas singular (and if you downloaded manually unpacked it)? The content of the folder should look sth like this and there you also see the pip needs to install the package

Additionally (don’t know if this is mentioned in the compas singular gitbook) you need to make every compas package aviable in rhino e.g. python -m compas_rhino.install -p compas_singular compas_skeleton compas_triangle compas_tna (you can just list the packages after the initial command).

Hi, Be cause of some problem in using compass , I reinstalled my windows again. But for installing compass, I have problem again. I havnt anaconda prompt. I just have prompt command. Is it necessary to install? which plugin?

C:\Users\Mohammadreza>conda config --add channels conda-forge
‘conda’ is not recognized as an internal or external command,
operable program or batch file.