Installation error - Failure to import compas_ags


I am trying to install Compas AGS and TNA. I downloaded Anaconda 3 and the package from here:

I am runing Anaconda as an administrator and didn’t installed it on PATH.

Everything is working up to the step:

import compas_ags

See prompt screen shot below. Thank you very much for your help.



I just realised the message error got cropped in the previous screenshot

hi zoe,

could you elaborate on the installation procedure?
did you use the environment file?


the screenshot seems to suggest the procedure never got past the AGS installation. this might be because we recently moved the compa_tna package to compas-dev and the url in the yml file still points at the BlockResearchGroup organisation. although this normally is handled by Github it might
not be the case for pip instructions.

another reason, and this is more likely, might be that you don’t have Git installed on your system. make sure to install it from here:

to check that it is available, just type git on the command line and press enter…

i will update the workshop repo, but after installing git, perhaps in the meantime you could run the following and report back:

conda activate IASS19
pip install git+
pip install git+
pip install git+ 

Hi Tom,

Thank you very much for your answer. I indeed did not had Git installed on my computer before. I have just download it and I ran the 4 lines you typed successfully.

Where should I start again the downloading process? Should I start at:

import compass_ags

Or should I directly go to:

python -m compas_rhino.install -v 6.0 -p compas compas_rhino compas_ags compas_tna

Thanks again for your time, I am not so familiar with Python/Anaconda, and coding in general.


hi zoe,

to checkk if everything installed properly, start an interactive Python interpreter and try to import the various packages.

>>> import compas
>>> import compas_tna
>>> import compas_ags
>>> import compas_3gs
>>> exit()

if that works without problems you could run the installation instructions for Rhino.

python -m compas_rhino.install -v 6.0 compas compas_rhino compas_ags compas_3gs compas_tna

All the imports went well. But I can’t do the Rhino install.

okay that can also be solved :slight_smile:

just do

conda install matplotlib=3.0

then run the rhino install command again

Thank you so much for helping me Tom!

I now get this error… I am a bit confused as I did import “compas”, “compas_tna” etc… and it seemed to be ok?

sorry, my mistake.

the rhino install command should have been

python -m compas_rhino.install -v 6.0 -p compas compas_rhino compas_ags compas_3gs compas_tna

with the -p flag before the list of packages…

Hi Tom,

It finally worked! very exciting!!! Thank you so much for your help step by step.


you are welcome. good luck!