No module named numpy - Rhino 7.0

When I import compas.geometry into rhino, it throws me the following error;
No module named numpy.

The problem is that it happens no matter what, even if I just run for example the single line import script

from compas.geometry import Plane

The traceback error leads me to “compas/geometry/transformations/transformation_numpy.py”

Any idea?

hi,

i think this might be related to the changed version of IronPython shipped with Rhino in recent updates. with this version compas doesn’t identify ipy correctly and will not prevent numpy libs to be loaded in Rhino.

if i am not mistaken, this should be fixed in the very latest release of compas. could you check if the problem also occurs with 1.14.1?

1 Like

Hi,

I have the same issue. after I updated my Rhino 7 to 7.15.(wasn’t an issue with 7.14) and I contacted Rhino, they said they fixed it in 7.16. but I checked it today the error is still there. My CAMPAS is 1.14.1. Do you know the reason?

Thanks

The ironpython misidentification issue should only exist in Rhino 7.16 as far as I know, but in any case, it should indeed be solved with compas 1.14.1.

@Cy_Wei does this occur with any script? Or do you have a specific example code that reproduces the issue?

1 Like

I just upgrade the rhino to 7.17, the problem has been solved. Thanks, @gonzalocasas

1 Like

Update to 1.14.1 solves the problem indeed.