Compas_singular grasshopper component error - installation problems

Hi all, total noob here, apologies for possible misconceptions and overall lack of understanding in advance.

After following installation steps for conda, compas and installing compas_singular, and successfully installing the latest versions of all of them, I wanted to load some of the grasshopper examples on github to see how they work.

Unfortunately, when I load the definition I get an error “1. Solution exception:cannot import surface_discrete_mapping from compas_singular.algorithms” - (see screenshot)

Following the error message I tried to look for the surface_discrete_mapping algorithm and it really seems it is missing, although I can see it clearly referenced in the code I cannot find where it was defined while for all the other algorithms used (boundary_triangulation, Skeleton and SkeletonDecompostion) I can. Im not sure if this is an issue regarding improper installation or with the code itself. No clue on what to do next either.

I would appreciate any suggestions on how to solve this error.


i am not the author of compas_singular so i can’t say for sure, but perhaps if you give me a bit more details about the installation of compas_singular i can try to help.

how did you install compas_singular, and which version?

does compas_singular work for other examples, or does it not work at all?


Hello tom, sorry for the late reply.

1.) Installed compas_singular following steps described here, the version installed is I guess the latest one

2.) None of the grasshopper example definitions using compas_singular work for me, always the same error message as in the first post

3.) following the error message from the first post, I saw that in there is this importing of the “surface _discrete_mapping” function/method from compas_singular.algorithms, I looked through the code and couldn’t find this function defined anywhere in compas_singular. That kind of gives me the idea that it’s either missing or it’s differently named in definition than when called in code or perhaps it’s located somewhere else, but I’m a novice so not sure if this holds.

Let me know if you need more details.